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Welcome to the IconBuilder Pro Tutorial

IconBuilder Pro is not an icon editor, but a tool you can use to
organize and streamline construction of icons for both the
Macintosh and Windows platforms and all version of their
operating systems.

The purpose of this tutorial is to familiarize you with the features
and controls of IconBuilder Pro through hands-on practice. We
recommend that all users read through the entire tutorial since
each section contains useful information about the filter and
icon creation that is not platform-specific.

The first section leads you through the steps to import art and
create an icon for Mac OS X using IconBuilder  Pro’s QuickBuild™
feature and the IconBuilder Assistant Photoshop Action.

Section two is devoted to how to create icons with Open /
Drop states that appear to animate in Mac OS X.

The last section mainly covers how to create icons for Windows
XP, but contains useful information for all users including
manually resizing icons and adding drop shadow effects.

Throughout the tutorial you will notice color coded words.
The Blue highlighted words represent actions. Orange
highlighted words represent locations.

A Step-By-Step Tutorial
IconBuilder Pro

This step-by-step guide assumes that you have read the
IconBuilder Pro User’s Guide and have a good understanding
of the interface and controls in the filter.

If you have not read the User’s Guide or are a beginner to
IconBuilder Pro, we recommend that you go back at this
time and read the User’s Guide before proceeding with
this tutorial.
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How To Install IconBuilder Pro

Drag and drop the IconBuilder Pro folder from the disk image you downloaded from The Iconfactory
into your Adobe Photoshop Plug-Ins folder. The Plug-Ins Folder should be located in the main
Applications folder of your Mac’s hard drive.

Loading IconBuilder Assistant (Photoshop Action)

The IconBuilder Assistant Photoshop Action file (IB Assistant.atn) included in the IconBuilder Pro
download is pre-built and ready to be loaded into Photoshop. Using IconBuilder Assistant can
greatly reduce the effort and time needed to construct Mac OS X icons by automatically creating
icon sizes from a base 128x128 graphic.

To load IconBuilder Assistant, launch Photoshop by clicking its application icon in the Dock. Once
running, activate the Actions palette by selecting Window > Actions from the main menu.

Next, click the small triangle on the top right side of the palette to access the menu options for
Actions. Select Load Actions... and a standard Mac OS X dialog box will open. (fig. 1)

Then, to locate the IconBuilder Assistant action file, navigate your hard drive using the following
route: Applications > Adobe Photoshop > Plug-Ins > IconBuilder Pro > Goodies > IB Assistant.atn
Select and click Load to import the action into Photoshop (fig. 2).

You are now ready to use IconBuilder Assistant. Simply select it from the Actions Palette or assign
it a command-key shortcut.

Uninstalling IconBuilder Pro

To uninstall IconBuilder Pro, simply drag the IconBuilder Pro folder to the Trash. The folder should
be located on your hard drive in Applications > Adobe Photoshop > Plug-ins.

Locate IconBuilder Assistant (fig. 2) - IconBuilder Assistant is located in the
Goodies folder of the main IconBuilder Pro download under the  filename
IB Assistant.atn.

Load IconBuilder Assistant (fig. 1) - IconBuilder Assistant must be loaded from
within Adobe Photoshop before you can use it.

A Step-By-Step Tutorial
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1) Setting Up The Work Area

• Open the IconBuilder Grid.psd file located in the
 / Applications / Adobe Photoshop / Plug-Ins /
IconBuilder Pro 4 / Goodies folder.

This file is formatted for the sizes most commonly used when
creating Mac OS X icons.  It consists of 16, 32, 48, and 128
pixel squares for placing your icons into during the production
process.

A Step-By-Step Tutorial
IconBuilder Pro

Introduction

There are many different approaches that can be taken to
create a Macintosh OS X icon. The process that is outlined in
this section is the most direct, and by far the easiest method
for going from raw artwork to a finished icon.

The goal of this section is to familarize you with the basic
controls of IconBuilder Pro including the QuickBuild™ command
and the IconBuilder Assistant Action that comes with the filter.

When IconBuilder Assistant is used in conjunction with 128x128
base art, a Mac OS X icon can be generated in just a few
mouse clicks. This saves a great deal of time and lets you focus
on finetuning the design of the icon itself instead of its
construction. Also covered are some tips and tricks that come
in handy when building Mac OS X icons.

We recommend that you DO NOT alter the position of
the squares in the IconBuilder Grid.psd. The IconBuilder
Assistant Action (ATN) relies on the default arrangement
of the squares to function properly.

(fig. 3)
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2) Importing & Placing the 128x128 Pixel Art

• Open the Closed Folder.eps file in the Goodies folder.

• Enter 120 pixels in the height field of the Rasterize 
Generic EPS Format dialog box and click OK. (fig. 4)

• Make the Closed Folder.eps the active document and 
choose All from the Select Menu.

• Choose Copy from the Edit Menu or type Command-C to
copy the selected image.

• Click on the IconBuilder Grid.psd file to make it the 
active document.

• Choose Paste from the Edit Menu or type Command-V. 
The Closed Folder.eps file will be copied to a new layer 
called Layer 1.

• Use the Hand tool to center the image of the folder 
within the 128x128 square.

3) Running The IconBuilder Assistant Action

• While keeping Layer 1 active, go to the Actions Pallete
and highlight the action named Copy 128 to others 
and click Play Selection (the triangular icon at the bottom
of the Actions palette). (fig. 5)

The IconBuilder Assistant helps you by automatically creating
the other sizes you will need. This greatly reduces the time it
takes to manually resize the image for the other icon resources.

If you prefer to resize the artwork by hand (add sharpening or
other effects, etc.) you may do so, but be sure to merge your
layers prior to launching the filter or QuickBuild™ will not
function properly.

A Step-By-Step Tutorial
IconBuilder Pro

(fig. 5)

(fig. 4)
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4) Launch IconBuilder Pro

• Make sure Layer 1 is highlighted and select  Filter >
Iconfactory > IconBuilder Pro 4.0 to launch the software.
(fig. 6)

The first time the filter is launched, you will see a help screen
that provides some useful tips and tricks. On subsequent
launches these tips will not appear.

5) Use Quickbuild™ To Construct The Icon

After IconBuilder Pro has launched, you will notice that the
48x48 grid cell is selected by default.

• While holding down the Option Key, click the QuickBuild™
button. (fig. 5)

This command will fill all of the sizes and bit depths in the
Icon Resource Grid. If you click on the Aqua Tab, you can
view the 128x128 pixel resource that has been added to your
icon.

A Step-By-Step Tutorial
IconBuilder Pro

(fig. 6)

You can easily tell if there is data in a particular view by
the small indicator lights on the tabs and buttons. If
these indicators are green, than that view contains icon
data. If it is grayed out, than the view is empty.

(fig. 7)
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6) Saving Your Icon To The Desktop

• Check that the Platform Menu is set to Mac and the
OS/File Type Menu is set to All.

• Click Save to open the Save dialog box.

• Navigate to your Desktop to save the icon and
name the file Smoothicons Folder. (fig. 8)

• Click Save.

• Click Done to exit the IconBuilder Pro 4.0 filter.

You can now go to the Desktop to view your icon.
Congratulations, you've created your first icon with
IconBuilder Pro!

A Step-By-Step Tutorial
IconBuilder Pro

(fig. 8)
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Introduction

Mac OS 10.2 introduced the use of “icon states.” This allows
an artist to design and produce icons that change visually when
certain things happen in the Finder. As of Mac OS 10.2.3, the
only states currently supported by Apple are the Normal and
Open / Drop states.

The Open / Drop state is a secondary set of resources in the
icon file that makes the icon appear to move when a file or
folder is dragged over it.

The goal of this section is to familiarize you with IconBuilder
Pro’s “icon states” controls and custom save options.

1) Rasterizing the Open / Drop Version

The Open / Drop state is a secondary set of resources in the
icon file that makes the folder appear to “open” when a file
or folder is dragged over it.

• Double-click the Open Folder.eps file from the / Applications
 / Adobe Photoshop / Plug-Ins / IconBulder Pro 4.0 / Goodies
folder to open it.

• After the Rasterize Generic EPS Format dialog box appears
on screen, enter 120 in the Height field and click OK. (fig. 9)

• Make the Open Folder.eps the active window and choose 
All from the Select menu.

• Choose Copy from the Edit Menu or type Command-C to 
copy the image.

• Click on the IconBuilder Grid.psd to make it the active
window.

• Choose Paste from the Edit Menu or type Command-V to 
paste the image onto a new Layer.

A Step-By-Step Tutorial
IconBuilder Pro

(fig. 9)
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2) Align the Image & Run IconBuilder Assistant
• Use the Hand tool to move the image of the folder around

to overlay the version of the Closed Folder as closely as 
possible.

It is important to make sure the two folders line up precisely
to prevent the icon from appearing to “jump” when a user
drags a file over it.

• Make sure the layer with the Open Folder.eps is selected 
and click Play on the Copy 128 to others Action. (fig. 10)
The additional sizes will be created and placed on a
single layer.

3) Add the Open / Drop Resources to the Existing Icon

• Click on the Filter menu and choose Iconfactory > 
IconBuilderPro 4.0 to run the filter.

Once you are within the filter you will notice that the Closed
Folder icon you created earlier will still be in the Icon Resources
Grid.

• Click the Open/Drop button from the Icon Resources 
section (at the top of the filter’s interface) to display the 
Open / Drop state resource grid.

• Hold the Option key while clicking the QuickBuild™ button
to fill in the grid. (fig. 11)

A Step-By-Step Tutorial
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(fig. 10)

(fig. 11)

You’ll be able to tell if the Open / Drop state isn’t aligned
with the normal state by clicking the two state buttons
and comparing the visual display. You can make small
adjustments to the position of the graphic in the grid cell
using the arrow keys to nudge the layer.
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4) Saving the Icon as a Custom Folder

Now that you have added the Open / Drop state information
to the icon, you need to set the Save Options to include that
information in your final file. Otherwise, left in default mode
IconBuilder Pro will save the icon as an icon resource which
will not display the second state you just added.

• Click Save Options and choose Folder with custom icon in 
the Save As pop-up. (fig. 12)

• Click OK.

• Choose Save from the filter window. When you name the 
file, be sure to give it a new, unique name.

• Click Save.

Congratulations! Your folder will now have a second state and
will “magically” pop open when you drag a document or
folder over it in the Macintosh Finder.

When building a desktop icon that contains an Open
/ Drop state, you MUST use the Save Options to set the
save format to Folder with Custom Icon. Saving the
icon as a standard resource file will not format the icon
correctly and you will not see the Open / Drop state
function in the Mac OS X Finder.

However, since IconBuilder Pro cannot read the states
from an icon saved in this fashion, we recommend that
this is the final step you perform when constructing
Open / Drop folders.

A Step-By-Step Tutorial
IconBuilder Pro

(fig. 12)
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Introduction

The goal of this section is to familiarize you with how to
manually resize images to fit each appropriate grid cell, add
XP-style drop shadows, and save icons for the Windows
platform.

The manual process does take longer, but can give you more
precise placing and sizing control than using the IconBuilder
Assistant action. This is important as you will also add the XP
style drop shadow to the image and will need adequate room
to place the icon in the grid cell.

The file you will be working with is formatted for Mac OS X
and consists of 16, 32, 48, and 128 pixel squares.  In this
section you will only use the 16, 32 and 48 pixel sizes since
those are the Windows XP sizes most commonly used.

A Step-By-Step Tutorial
IconBuilder Pro

1) Rasterize the XP Folder Base Art

• Open the Document.eps file located in the 
/ Applications / Adobe Photoshop / Plug-Ins / IconBuilder 
Pro 4  / Goodies folder.

• Enter a value of 44 pixels in the Width field of the
Rasterize Generic EPS Format dialog box. (fig. 13)

You entered 44 pixels in the Width field instead of 48 pixels
to allow enough room to apply a drop shadow later.

• Click OK.

(fig. 13)
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2) Increase the Canvas Size

• Choose Canvas from the Image menu.

• Enter a value of 48 pixels into both the Height and Width 
fields. (fig. 14)

• Make Document.eps the active window and choose All from
the Select menu.

• Select Copy from the Edit menu or type Command-C.

• Click the IconBuilder Grid.psd file to make it active.

• Choose Paste from the Edit menu or type Command-V to 
paste the image onto a new layer.

3) Resize the Image for the 32x32 & 16x16 Versions

In this step, we’re going to fill the 32x32 and 16x16 template
squares manually. The trick is to leave enough space (usually
at least 2 pixels) for the application of the XP drop shadow.
Therefore, before the drop shadow is added, the maximum
width or height XP icons should be is 30x30 and 14x14 pixels.

Sometimes, artists choose not to apply the drop shadow to
the smaller version of the icon, in which case you can use the
full 16x16 size.

• Select Image Size from the Image menu.

• Set the Width of the image to 30 pixels. (fig. 15)

• Copy the image and paste it into the IconBuilder Grid.psd.

• Use the Hand tool to position it within the 32x32 square.

• Return to the image you just resized. Select Image Size 
again and set the Width to 14x14 pixels.

• Copy and paste the image into the IconBuilder Grid.psd.

• Use the Hand tool to position it within the 16x16 square.

A Step-By-Step Tutorial
IconBuilder Pro

(fig. 14)

(fig. 15)
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4) Merge the Layers Into One

You should now have three individual layers, each one containing
a different version of the icon. Before you add the XP drop
shadow to these icons and run the filter, you must merge the
layers into a single layer.

• Select Layer 3 to highlight it.

• Select Layer > Merge Down (Command-E). This will merge
Layer 3 down to Layer 2. (fig. 16)

• Repeat with Layer 2. This will leave you with one layer that
will contain all three image sizes.

5) Add the XP Drop Shadow

Now that the layers are merged, use Photoshop’s built-in Layer
Effects to add the XP-style drop shadow to the icon.

• Choose Layer > Layer Style > Drop Shadow...

• Enter the following values into the Drop Shadow area: (fig. 17)

Blending Mode: Multiply
Opacity 75%
Angle: 135
Distance: 2
Spread: 0
Size: 2

• Click OK.

A Step-By-Step Tutorial
IconBuilder Pro

(fig. 16)

(fig. 17)
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6) Merge the Layer Effect

In order for IconBuilder Pro to read the drop shadow correctly
you’ll need to merge the Layer Effect onto the layer itself.

• Create a new layer (Command-N).

• Drag Layer 1 below the layer containing the icons.

• Toggle the visibility for all other layers off by clicking the 
small “eye icons” to the left of each layer. You should now
only see the icons and the checkerboard pattern of the 
transparent background.

• Choose Merge Visible from the Layer menu. This will merge
the drop shadow effect with the icons into a single layer 
that Iconbuilder Pro can use. (fig. 18)

7) Run IconBuilder Pro, Align, & QuickBuild™

• Highlight the new, merged layer by selecting it.

• Run IconBuilder 4.0 from the Filter menu.

• Click and select Windows from the Platform pull-down menu
to build the icon for Windows instead of the Macintosh.

• Select the 48x48, 32-bit grid cell by clicking on it.

• Center the icon to your satisfaction in the Photoshop Layer
window (on the left).

• Hold down the Option key and click the QuickBuild™ button.
(fig. 19)

This will fill the grid in completely. Notice the heavy black
shadows on all the 4-bit and 8-bit versions. This happens
because of the lack of 256 levels of transparency in these
resources. The gray, semi-transparent pixels of the drop shadow
are converted to either on (black) or off (white).

In order for this icon to look as good as possible on eariler
versions of Windows that do not support 32-bit icons, these
layers must be cleaned up and added back into the icon.

A Step-By-Step Tutorial
IconBuilder Pro

(fig. 18)

(fig. 19)
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8) Extract the 48x48 Resource to Photoshop for Editing

Before you can edit the 48x48 resource, you need to save the
current version of the icon for later reference.

• Click Save and name your icon.

Before you can edit the 48x48/ 8-bit version, you need to
create a new, blank layer so you do not erase the previous
work you’ve already accomplished.

• Click Done and then OK when asked to discard the changes.

• Create a new layer and name it 48 8-bit.

• Make sure the layer is selected by clicking on it.

• Choose IconBuilderPro 4.0 from the Filter Menu.

• Highlight the 48x48 pixel/8-bit grid cell and click Apply to 
Photoshop Layer. (fig. 20)

The icon is copied to the new layer and can now be edited to
remove the opaque shadow. If you had simply clicked the
Apply to Photoshop Layer button without creating a new layer
first, the icons on the current layer would have been erased
and replaced with this version instead.

9) Replace the 48x48 8-Bit Resource

Now that the icon is copied to the new layer, you can use
Photoshop’s pencil and eraser tools to erase the heavy, dark
pixels that were created by the drop shadow and clean up any
dithering with which you are not satisfied.

Cleaning up drop shadows or other edges on Mac icons is not
recommended because it will leave a “halo” effect due to a
shared mask problem.

After you have edited the icon to your liking, you’ll need to
add it back into the icon resource.

• Click the 48 8-bit layer to make sure it is selected.

• Launch IconBuilder Pro from the Filter Menu.

• After Iconbuilder launches, select the 48x48/8-bit grid cell.

You will see the old icon in the Target Icon window on the
right side where you applied it to a Photoshop layer.

• Center the icon in the Source Layer (on the left side).

• Click Both to add only the single icon resource. If the icon 
shifts position too much, realign it in the Source Layer on 
the left and click Both again. (fig. 21)

• Once you are satisfied with the placement of the resource,
click Save to save the icon. Leave the file name the same, 
and simply save over the previous version.

A Step-By-Step Tutorial
IconBuilder Pro

(fig. 20)

(fig. 21)
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10) Replace Other Resources & Test

You can continue to clean up and replace the other resources
within the icon by repeating Steps 8 and 9. Apply the resource
to a Photoshop layer, clean it up, and then use the Add Both
button to replace the existing version with the clean one. Save
over the file each time. When you are done you will be left
with a version of the icon that will look as good as possible
across all versions of Windows.

Finally, it is important to bring your .ico file to a Windows PC
and view it to make sure the icon is displaying correctly. An
executable file named ICONTEST.EXE will help you test your
icons in a Windows user interface. It is located in the Goodies
> Windows folder of the IconBuilder Pro download.

There are other tips and tricks when dealing with Windows
icons. Be sure to read the IconBuilder Pro User’s Guide and
check The Iconfactory website’s FAQ pages for the latest
IconBuilder Pro information.
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